]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-DSA.git/blob - perl-Crypt-OpenSSL-DSA.spec
cb82a7c626449a5c04c0a28ac3b5074318639e12
[packages/perl-Crypt-OpenSSL-DSA.git] / perl-Crypt-OpenSSL-DSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-DSA
7 Summary:        Crypt::OpenSSL::DSA - Digital Signature Algorithm using OpenSSL
8 Summary(pl.UTF-8):      Crypt::OpenSSL::DSA - algorytm DSA używający OpenSSL
9 Name:           perl-Crypt-OpenSSL-DSA
10 Version:        0.19
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  53a663536519d1be07a538790b937218
17 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-DSA/
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  openssl-tools
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  which
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Crypt::OpenSSL::DSA implements the DSA (Digital Signature Algorithm)
27 signature verification system.
28
29 %description -l pl.UTF-8
30 Moduł Crypt::OpenSSL::DSA jest implementacją systemu weryfikacji
31 podpisów DSA (Digital Signature Algorithm).
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Crypt/OpenSSL/DSA/Signature.pod
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Crypt/OpenSSL/DSA.pm
60 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA
61 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA/DSA.so
62 %{_mandir}/man3/Crypt::OpenSSL::DSA*.3pm*
This page took 0.053312 seconds and 2 git commands to generate.