]> git.pld-linux.org Git - packages/perl-Crypt-DSA.git/blob - perl-Crypt-DSA.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-DSA.git] / perl-Crypt-DSA.spec
1 #
2 # Conditional build
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    DSA
7 Summary:        Crypt::DSA Perl module - DSA signature and key generation
8 Summary(pl.UTF-8):      Moduł Perla Crypt::DSA - generujący sygnatury i klucze DSA
9 Name:           perl-Crypt-DSA
10 Version:        1.17
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0a64dcd77e796ebacad4c6af2df74b57
17 URL:            http://search.cpan.org/dist/Crypt-DSA/
18 %if %{with tests}
19 BuildRequires:  perl-Data-Buffer >= 0.01
20 BuildRequires:  perl-Digest-SHA1
21 BuildRequires:  perl-File-Which >= 0.05
22 BuildRequires:  perl-Math-BigInt >= 1.78
23 BuildRequires:  perl-Math-BigInt-GMP
24 %endif
25 BuildRequires:  perl-Convert-PEM >= 0.07
26 BuildRequires:  perl-devel >= 1:5.8.0
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 Requires:       perl-File-Which >= 0.05
29 Requires:       perl-Math-BigInt >= 1.78
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # optional
34 %define         _noautoreq 'perl(Convert::PEM)' 'perl(Data::Buffer)'
35
36 %description
37 Crypt::DSA is an implementation of the DSA (Digital Signature
38 Algorithm) signature verification system. The implementation itself is
39 pure Perl, although the heavy-duty mathematics underneath are provided
40 by the Math::Pari library. This package provides DSA signing,
41 signature verification, and key generation. It additionally requires
42 Convert::PEM >= 0.04 module to read/write PEM-encoded files and
43 Data::Buffer >= 0.01 module to read/write SSH2 keyfiles.
44
45 %description -l pl.UTF-8
46 Crypt::DSA jest implementacją systemu weryfikacji sygnatur DSA
47 (Digital Signature Alghorithm). Sama implementacja jest w czystym
48 Perlu, ale do ciężkiej matematyki korzysta z biblioteki Math::Pari.
49 Pakiet umożliwia podpisywanie i weryfikację sygnatur DSA oraz
50 generowanie kluczy. Moduł ten wymaga dodatkowo modułu Convert::PEM w
51 wersji >= 0.04 do czytania i zapisywania plików zakodowanych PEM oraz
52 modułu Data::Buffer w wersji >= 0.01 do czytania i zapisywania plików
53 z kluczami SSH2.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62 %{?with_tests: %{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/Crypt/DSA.pm
77 %{perl_vendorlib}/Crypt/DSA
78 %{_mandir}/man3/*
This page took 0.154005 seconds and 4 git commands to generate.