]> git.pld-linux.org Git - packages/perl-Crypt-DES.git/blob - perl-Crypt-DES.spec
- release 6
[packages/perl-Crypt-DES.git] / perl-Crypt-DES.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    DES
8 Summary:        Crypt::DES - Perl DES encryption module
9 Summary(pl.UTF-8):      Crypt::DES - moduł Perla dla szyfrowania DES
10 Name:           perl-Crypt-DES
11 Version:        2.05
12 Release:        6
13 License:        BSD-like (see COPYRIGHT)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a8a0bea7064e11d2af434f3e468c17bb
17 URL:            http://search.cpan.org/dist/Crypt-DES/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Crypt::DES is Perl interface to DES block cipher.
24
25 %description -l pl.UTF-8
26 Moduł Perla Crypt::DES zawiera obsługę algorytmu szyfrowania DES.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make} \
35         CC="%{__cc}" \
36         OPTIMIZE="%{rpmcflags}"
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc COPYRIGHT README
52 %{perl_vendorarch}/Crypt/DES.pm
53 %dir %{perl_vendorarch}/auto/Crypt/DES
54 %{perl_vendorarch}/auto/Crypt/DES/DES.bs
55 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/DES/DES.so
56 %{_mandir}/man3/*
This page took 0.047158 seconds and 4 git commands to generate.