]> git.pld-linux.org Git - packages/perl-Crypt-DES.git/blob - perl-Crypt-DES.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-DES.git] / perl-Crypt-DES.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    DES
7 Summary:        Crypt::DES - Perl DES encryption module
8 Summary(pl.UTF-8):      Crypt::DES - moduł Perla dla szyfrowania DES
9 Name:           perl-Crypt-DES
10 Version:        2.07
11 Release:        13
12 License:        BSD-like (see COPYRIGHT)
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  e845d24cf383ca4a30a3380a2735feac
16 URL:            https://metacpan.org/dist/Crypt-DES
17 %{?with_tests:BuildRequires:    perl-Crypt-CBC}
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::DES is Perl interface to DES block cipher.
25
26 %description -l pl.UTF-8
27 Moduł Perla Crypt::DES zawiera obsługę algorytmu szyfrowania DES.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         CC="%{__cc}" \
37         OPTIMIZE="%{rpmcflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc COPYRIGHT README
53 %{perl_vendorarch}/Crypt/DES.pm
54 %dir %{perl_vendorarch}/auto/Crypt/DES
55 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/DES/DES.so
56 %{_mandir}/man3/Crypt::DES.3pm*
This page took 0.100174 seconds and 3 git commands to generate.