]> git.pld-linux.org Git - packages/perl-Crypt-Blowfish.git/blob - perl-Crypt-Blowfish.spec
- added tests
[packages/perl-Crypt-Blowfish.git] / perl-Crypt-Blowfish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Blowfish
8 Summary:        Crypt::Blowfish - Perl Blowfish encryption module
9 Summary(pl):    Crypt::Blowfish - modu³ Perla dla szyfrowania Blowfish
10 Name:           perl-Crypt-Blowfish
11 Version:        2.09
12 Release:        5
13 License:        BSD-like (see COPYRIGHT)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bbd037e1eb20778f3d636dff345ed02f
17 BuildRequires:  perl-devel >= 5.6.1
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Crypt::Blowfish Perl module contains an implementation of the Blowfish
23 cryptography algorithm.
24
25 %description -l pl
26 Modu³ Perla Crypt::Blowfish zawiera implementacjê algorytmu
27 kryptograficznego Blowfish.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         OPTIMIZE="%{rpmcflags}"
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes COPYRIGHT README
52 %{perl_vendorarch}/Crypt/Blowfish.pm
53 %dir %{perl_vendorarch}/auto/Crypt/Blowfish
54 %{perl_vendorarch}/auto/Crypt/Blowfish/*.bs
55 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Blowfish/*.so
56 %{_mandir}/man3/*
This page took 0.059725 seconds and 4 git commands to generate.