]> git.pld-linux.org Git - packages/perl-Config-Tiny.git/blob - perl-Config-Tiny.spec
- updated to 2.26
[packages/perl-Config-Tiny.git] / perl-Config-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Config
6 %define         pnam    Tiny
7 Summary:        Config::Tiny - Read/Write .ini style files with as little code as possible
8 Summary(pl.UTF-8):      Config::Tiny - czytanie/zapisywanie plików w stylu .ini w minimalnym kodzie
9 Name:           perl-Config-Tiny
10 Version:        2.26
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Config/%{pdir}-%{pnam}-%{version}.tgz
16 # Source0-md5:  760485706daa91a22485421c3c2b1e1d
17 URL:            https://metacpan.org/release/Config-Tiny
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(File::Spec) >= 3.30
23 BuildRequires:  perl-File-Temp >= 0.22
24 BuildRequires:  perl-Test-Simple >= 1.001002
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Config::Tiny is a Perl class to read and write .ini style
31 configuration files with as little code as possible, reducing load
32 time and memory overhead. Memory usage is normally scoffed at in Perl,
33 but in my opinion should be at least kept in mind.
34
35 This module is primarily for reading human written files, and anything
36 we write shouldn't need to have documentation/comments. If you need
37 something with more power, move up to Config::Simple, Config::General
38 or one of the many other Config:: modules. To rephrase, Config::Tiny
39 does not preserve your comments, whitespace, or the order of your
40 config file.
41
42 %description -l pl.UTF-8
43 Config::Tiny to klasa Perla do odczytu i zapisu plików
44 konfiguracyjnych w stylu .ini przy użyciu tak małego kodu, jak to
45 możliwe, co zmniejsza czas ładowania i użycie pamięci. Użycie pamięci
46 jest zwykle wyśmiewane w Perlu, ale zdaniem autora powinno być
47 przynajmniej brane pod uwagę.
48
49 Ten moduł służy głównie do czytania plików napisanych przez ludzi i
50 wszystko co zapisujemy nie powinno potrzebować dokumentacji czy
51 komentarzy. Jeśli potrzebujemy czegoś o większych możliwościach,
52 można przerzucić się na Config::Simple, Config::General lub jeden z
53 wielu innych modułów Config::. Innymi słowy, Config::Tiny nie
54 zachowuje komentarzy, odstępów ani porządku w pliku konfiguracyjnym.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorlib}/Config/Tiny.pm
79 %{_mandir}/man3/Config::Tiny.3pm*
This page took 0.119481 seconds and 4 git commands to generate.