]> git.pld-linux.org Git - packages/perl-Config-IniFiles.git/blob - perl-Config-IniFiles.spec
- rel. 2
[packages/perl-Config-IniFiles.git] / perl-Config-IniFiles.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Config
7 %define pnam    IniFiles
8 Summary:        Config::IniFiles - a module for reading .ini-style configuration files
9 Summary(pl):    Config::IniFiles - modu³ do odczytu plików konfiguracyjnych typu .ini
10 Name:           perl-Config-IniFiles
11 Version:        2.38
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  17e39e4244ede0061939dcb80ab6294e
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Config::IniFiles Perl module provides a way to have readable
25 configuration files outside your Perl script.  Configurations can be
26 imported (inherited, stacked,...), sections can be grouped, and
27 settings can be accessed from a tied hash.
28
29 %description -l pl
30 Modu³ Perla Config::IniFiles umo¿liwia posiadanie czytelnych plików
31 konfiguracyjnych poza skryptem perlowym. Konfiguracjê mo¿na
32 zaimportowaæ (odziedziczyæ, umie¶ciæ na stosie, ...), sekcje mo¿na
33 pogrupowaæ a dostêp do ³añcuchów tekstowych mo¿e siê odbywaæ poprzez
34 stowarzyszony z plikiem hash.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README
58 %{_mandir}/man3/*
59 %{perl_vendorlib}/Config/IniFiles.pm
This page took 0.091054 seconds and 4 git commands to generate.