]> git.pld-linux.org Git - packages/perl-Config-Grammar.git/blob - perl-Config-Grammar.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Config-Grammar.git] / perl-Config-Grammar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Config
6 %define         pnam    Grammar
7 Summary:        Config::Grammar - A grammar-based, user-friendly config parser
8 Name:           perl-Config-Grammar
9 Version:        1.10
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Config/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  ce904f687f1ee9c70521142a2e0f15c9
15 URL:            http://search.cpan.org/dist/Config-Grammar/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Config::Grammar is a module to parse configuration files.
23
24 The configuration may consist of multiple-level sections with
25 assignments and tabular data. The parsed data will be returned as a
26 hash containing the whole configuration. Config::Grammar uses a
27 grammar that is supplied upon creation of a Config::Grammar object to
28 parse the configuration file and return helpful error messages in case
29 of syntax errors. Using the makepod method you can generate
30 documentation of the configuration file format.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{perl_vendorlib}/Config/*.pm
54 %{perl_vendorlib}/Config/Grammar
55 %{_mandir}/man3/*
This page took 0.086239 seconds and 4 git commands to generate.