]> git.pld-linux.org Git - packages/perl-Clone.git/commitdiff
initial, nfy
authorMaciej Pijanka <agaran@pld-linux.org>
Tue, 13 Apr 2004 05:17:10 +0000 (05:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-Clone.spec -> 1.1

perl-Clone.spec [new file with mode: 0644]

diff --git a/perl-Clone.spec b/perl-Clone.spec
new file mode 100644 (file)
index 0000000..fbc0f28
--- /dev/null
@@ -0,0 +1,52 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    Clone
+Summary:       Clone - recursively copy Perl datatypes
+Name:          perl-Clone
+Version:       0.15
+Release:       1
+# as perl itself
+License:       GPL or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
+# Source0-md5: 5cac94da96835758462133f3afd8fe22
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module provides a clone() method which makes recursive copies
+of nested hash, array, scalar and reference types, including tied
+variables and objects.
+
+%prep
+%setup -q -n %{pdir}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorarch}/Clone.pm
+%{perl_vendorarch}/auto/Clone/Clone.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
+%{_mandir}/man3/*
This page took 0.0606179999999999 seconds and 4 git commands to generate.