]> git.pld-linux.org Git - packages/perl-Clone.git/blob - perl-Clone.spec
- updated to 0.22
[packages/perl-Clone.git] / perl-Clone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Clone
7 Summary:        Clone - Perl module for recursively copying Perl datatypes
8 Summary(pl):    Clone - modu³ Perla obs³uguj±cy rekursywne kopiowanie zmiennych w Perlu
9 Name:           perl-Clone
10 Version:        0.22
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Clone/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  f70af2c46fbb60acc4388908bfd37c2f
17 URL:            http://search.cpan.org/dist/Clone/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a clone() method which makes recursive copies
24 of nested hash, array, scalar and reference types, including tied
25 variables and objects.
26
27 %description -l pl
28 Ten modu³ dostarcza clone(), metodê s³u¿±c± do rekurencyjnego
29 kopiowania zagnie¿d¿onych tablic asocjacyjnych, tablic, skalarów i
30 referencji, w³±cznie ze zwi±zanymi zmiennymi i obiektami.
31
32 %prep
33 %setup -q -n %{pdir}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorarch}/Clone.pm
57 %{perl_vendorarch}/auto/Clone/Clone.bs
58 %attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
59 %{perl_vendorarch}/auto/Clone/autosplit.ix
60 %{_mandir}/man3/*
This page took 0.051044 seconds and 4 git commands to generate.