]> git.pld-linux.org Git - packages/perl-Clone.git/blob - perl-Clone.spec
- pl fixes
[packages/perl-Clone.git] / perl-Clone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Clone
7 Summary:        Clone - Perl module for recursively copying Perl datatypes
8 Summary(pl):    Clone - modu³ Perla obs³uguj±cy rekursywne kopiowanie zmiennych w Perlu
9 Name:           perl-Clone
10 Version:        0.15
11 Release:        1
12 # as perl itself
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  5cac94da96835758462133f3afd8fe22
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module provides a clone() method which makes recursive copies
23 of nested hash, array, scalar and reference types, including tied
24 variables and objects.
25
26 %description -l pl
27 Ten modu³ dostarcza clone(), metodê s³u¿±c± do rekurencyjnego
28 kopiowania zagnie¿d¿onych tablic asocjacyjnych, tablic, skalarów i
29 referencji, w³±cznie ze zwi±zanymi zmiennymi i obiektami.
30
31 %prep
32 %setup -q -n %{pdir}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37
38 %{__make} \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes
55 %{perl_vendorarch}/Clone.pm
56 %{perl_vendorarch}/auto/Clone/Clone.bs
57 %attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
58 %{_mandir}/man3/*
This page took 0.088247 seconds and 3 git commands to generate.