]> git.pld-linux.org Git - packages/perl-Clone.git/blob - perl-Clone.spec
77f6716bb846fa2fc19702076b31aace96d123d6
[packages/perl-Clone.git] / perl-Clone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Clone
7 Summary:        Clone - Perl module for recursively copying Perl datatypes
8 Summary(pl.UTF-8):      Clone - moduł Perla obsługujący rekursywne kopiowanie zmiennych w Perlu
9 Name:           perl-Clone
10 Version:        0.34
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Clone/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  6475432d91b1820eff1ae877ea5c8e3b
17 URL:            http://search.cpan.org/dist/Clone/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a clone() method which makes recursive copies
24 of nested hash, array, scalar and reference types, including tied
25 variables and objects.
26
27 %description -l pl.UTF-8
28 Ten moduł dostarcza clone(), metodę służącą do rekurencyjnego
29 kopiowania zagnieżdżonych tablic asocjacyjnych, tablic, skalarów i
30 referencji, włącznie ze związanymi zmiennymi i obiektami.
31
32 %prep
33 %setup -q -n %{pdir}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorarch}/Clone.pm
58 %attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
59 %{perl_vendorarch}/auto/Clone/autosplit.ix
60 %{_mandir}/man3/*
This page took 0.079028 seconds and 2 git commands to generate.