]> git.pld-linux.org Git - packages/perl-Class-WhiteHole.git/blob - perl-Class-WhiteHole.spec
- massive attack: change CPAN URLs
[packages/perl-Class-WhiteHole.git] / perl-Class-WhiteHole.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Class
3 %define pnam    WhiteHole
4 Summary:        %{pdir}::%{pnam} - prevent from inheriting AUTOLOAD
5 Summary(pl):    %{pdir}::%{pnam} - ochrona przed dziedziczeniem AUTOLOAD
6 Name:           perl-Class-WhiteHole
7 Version:        0.03
8 Release:        1
9 License:        GPL/Artistic
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 BuildRequires:  perl >= 5
13 BuildRequires:  rpm-perlprov >= 3.0.3-16
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Its possible to accidentally inherit an AUTOLOAD method.  Often this
19 will happen if a class somewhere in the chain uses AutoLoader or defines
20 one of their own.  This can lead to confusing error messages when method
21 lookups fail.
22
23 Sometimes you want to avoid this accidental inheritance.  In that case,
24 inherit from Class::WhiteHole.  All unhandled methods will produce normal
25 Perl error messages.
26
27 %description -l pl
28 Istnieje mo¿liwo¶æ przypadkowego odziedziczenia metody AUTOLOAD.  Czêsto
29 zdarzy siê to, gdy jedna z ³añcucha klas stosuje AutoLoader lub definiuje
30 w³asn±.  Mo¿e to spowodowaæ dziwne komunikaty b³êdów, gdy odszukanie metody
31 nie powiedzie siê.
32
33 Czasami chcesz unikn±æ przypadkowego dziedziczenia.  W takim wypadku,
34 odziedzicz po Class::WhiteHole.  Ka¿de wywo³anie nieistniej±cej metody
35 spowoduje zwyczajn± informacjê o b³êdzie perla.
36
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 perl Makefile.PL
43 %{__make}
44 #%{__make} test
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{perl_sitelib}/%{pdir}/*.pm
56 %{_mandir}/man3/*
This page took 0.0925 seconds and 4 git commands to generate.