]> git.pld-linux.org Git - packages/perl-Class-WhiteHole.git/blob - perl-Class-WhiteHole.spec
- mass commit: cosmetics (removed trailing white spaces)
[packages/perl-Class-WhiteHole.git] / perl-Class-WhiteHole.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Class
3 %define pnam    WhiteHole
4 Summary:        %{pdir}::%{pnam} - prevent from inheriting AUTOLOAD
5 Summary(pl):    %{pdir}::%{pnam} - ochrona przed dziedziczeniem AUTOLOAD
6 Name:           perl-Class-WhiteHole
7 Version:        0.03
8 Release:        2
9 License:        GPL/Artistic
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 # Source0-md5:  c14e55c571adbf1cd181aae61d99ab9e
13 BuildRequires:  perl-devel >= 5
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Its possible to accidentally inherit an AUTOLOAD method.  Often this
20 will happen if a class somewhere in the chain uses AutoLoader or defines
21 one of their own.  This can lead to confusing error messages when method
22 lookups fail.
23
24 Sometimes you want to avoid this accidental inheritance.  In that case,
25 inherit from Class::WhiteHole.  All unhandled methods will produce normal
26 Perl error messages.
27
28 %description -l pl
29 Istnieje mo¿liwo¶æ przypadkowego odziedziczenia metody AUTOLOAD.  Czêsto
30 zdarzy siê to, gdy jedna z ³añcucha klas stosuje AutoLoader lub definiuje
31 w³asn±.  Mo¿e to spowodowaæ dziwne komunikaty b³êdów, gdy odszukanie metody
32 nie powiedzie siê.
33
34 Czasami chcesz unikn±æ przypadkowego dziedziczenia.  W takim wypadku,
35 odziedzicz po Class::WhiteHole.  Ka¿de wywo³anie nieistniej±cej metody
36 spowoduje zwyczajn± informacjê o b³êdzie perla.
37
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46 #%%{__make} test
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorlib}/%{pdir}/*.pm
58 %{_mandir}/man3/*
This page took 0.075161 seconds and 4 git commands to generate.