]> git.pld-linux.org Git - packages/perl-Class-WhiteHole.git/blob - perl-Class-WhiteHole.spec
c14274be49fe9a1ea2b32fa05182b1d369d69ab0
[packages/perl-Class-WhiteHole.git] / perl-Class-WhiteHole.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Class
7 %define pnam    WhiteHole
8 Summary:        %{pdir}::%{pnam} - prevent from inheriting AUTOLOAD
9 Summary(pl):    %{pdir}::%{pnam} - ochrona przed dziedziczeniem AUTOLOAD
10 Name:           perl-Class-WhiteHole
11 Version:        0.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  43b986ad7d5d186a9a43d2d69a2ef327
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Its possible to accidentally inherit an AUTOLOAD method.  Often this
25 will happen if a class somewhere in the chain uses AutoLoader or defines
26 one of their own.  This can lead to confusing error messages when method
27 lookups fail.
28
29 Sometimes you want to avoid this accidental inheritance.  In that case,
30 inherit from Class::WhiteHole.  All unhandled methods will produce normal
31 Perl error messages.
32
33 %description -l pl
34 Istnieje mo¿liwo¶æ przypadkowego odziedziczenia metody AUTOLOAD.  Czêsto
35 zdarzy siê to, gdy jedna z ³añcucha klas stosuje AutoLoader lub definiuje
36 w³asn±.  Mo¿e to spowodowaæ dziwne komunikaty b³êdów, gdy odszukanie metody
37 nie powiedzie siê.
38
39 Czasami chcesz unikn±æ przypadkowego dziedziczenia.  W takim wypadku,
40 odziedzicz po Class::WhiteHole.  Ka¿de wywo³anie nieistniej±cej metody
41 spowoduje zwyczajn± informacjê o b³êdzie perla.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/%{pdir}/*.pm
64 %{_mandir}/man3/*
This page took 0.042798 seconds and 2 git commands to generate.