]> git.pld-linux.org Git - packages/perl-Class-WhiteHole.git/blob - perl-Class-WhiteHole.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-WhiteHole.git] / perl-Class-WhiteHole.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    WhiteHole
7 Summary:        Class::WhiteHole - prevent from inheriting AUTOLOAD
8 Summary(pl.UTF-8):      Class::WhiteHole - ochrona przed dziedziczeniem AUTOLOAD
9 Name:           perl-Class-WhiteHole
10 Version:        0.04
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  43b986ad7d5d186a9a43d2d69a2ef327
17 URL:            http://search.cpan.org/dist/Class-WhiteHole/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Its possible to accidentally inherit an AUTOLOAD method. Often this
25 will happen if a class somewhere in the chain uses AutoLoader or
26 defines one of their own. This can lead to confusing error messages
27 when method lookups fail.
28
29 Sometimes you want to avoid this accidental inheritance. In that case,
30 inherit from Class::WhiteHole. All unhandled methods will produce
31 normal Perl error messages.
32
33 %description -l pl.UTF-8
34 Istnieje możliwość przypadkowego odziedziczenia metody AUTOLOAD.
35 Często zdarzy się to, gdy jedna z łańcucha klas stosuje AutoLoader lub
36 definiuje własną. Może to spowodować dziwne komunikaty błędów, gdy
37 odszukanie metody nie powiedzie się.
38
39 Czasami chcesz uniknąć przypadkowego dziedziczenia. W takim wypadku,
40 odziedzicz po Class::WhiteHole. Każde wywołanie nieistniejącej metody
41 spowoduje zwyczajną informację o błędzie Perla.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/%{pdir}/*.pm
64 %{_mandir}/man3/*
This page took 0.282937 seconds and 3 git commands to generate.