]> git.pld-linux.org Git - packages/perl-Class-Unload.git/blob - perl-Class-Unload.spec
- pl, completed dependencies
[packages/perl-Class-Unload.git] / perl-Class-Unload.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    Class
6 %define         pnam    Unload
7 Summary:        Class::Unload - unload a class
8 Summary(pl.UTF-8):      Class::Unload - wyładowanie klasy
9 Name:           perl-Class-Unload
10 Version:        0.11
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0c28497de640aea4c3900fb52b7c6cb5
17 URL:            https://metacpan.org/dist/Class-Unload
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Class-Inspector
24 BuildRequires:  perl-Test-Requires
25 BuildRequires:  perl-Test-Simple >= 0.88
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Unloads the given class by clearing out its symbol table and removing
32 it from INC hash.
33
34 %description -l pl.UTF-8
35 Moduł wyładowuje podaną klasę czyszcząc jego tablicę symboli i
36 usuwając ją z hasza INC.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Class/Unload.pm
61 %{_mandir}/man3/Class::Unload.3pm*
This page took 0.136884 seconds and 4 git commands to generate.