]> git.pld-linux.org Git - packages/perl-Class-Tiny.git/blob - perl-Class-Tiny.spec
- macros for perl autodeps
[packages/perl-Class-Tiny.git] / perl-Class-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    Tiny
7 Summary:        Class::Tiny - Minimalist class construction
8 Summary(pl.UTF-8):      Class::Tiny - minimalistyczne tworzenie klas
9 Name:           perl-Class-Tiny
10 Version:        1.006
11 Release:        1
12 License:        Apache v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fa905646a85a1478b2db1fc9113cb6ac
16 URL:            https://metacpan.org/release/Class-Tiny
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.96
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module offers a minimalist class construction kit in around 120
29 lines of code.
30
31 %description -l pl.UTF-8
32 Ten moduł oferuje minimalny zestaw konstrukcyjny do tworzenia klas w
33 około 120 liniach kodu.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorlib}/Class/Tiny.pm
58 %{_mandir}/man3/Class::Tiny.3pm*
This page took 0.057692 seconds and 4 git commands to generate.