]> git.pld-linux.org Git - packages/perl-Class-Refresh.git/blob - perl-Class-Refresh.spec
- pl, cleaned dependencies
[packages/perl-Class-Refresh.git] / perl-Class-Refresh.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    Refresh
7 Summary:        Class::Refresh - refresh your classes during runtime
8 Summary(pl.UTF-8):      Class::Refresh - odświeżanie klas w czasie działania
9 Name:           perl-Class-Refresh
10 Version:        0.07
11 Release:        2
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  12d9332777c7654368010548386aa2d9
17 URL:            https://metacpan.org/dist/Class-Refresh
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Class-Load
24 BuildRequires:  perl-Class-Unload
25 BuildRequires:  perl-Devel-OverrideGlobalRequire
26 BuildRequires:  perl-Test-Fatal
27 BuildRequires:  perl-Test-Requires
28 BuildRequires:  perl-Test-Simple >= 0.88
29 BuildRequires:  perl-Try-Tiny
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 During development, it is fairly common to cycle between writing code
36 and testing that code. Generally the testing happens within the test
37 suite, but frequently it is more convenient to test things by hand
38 when tracking down a bug, or when doing some exploratory coding. In
39 many situations, however, this becomes inconvenient - for instance, in
40 a REPL, or in a stateful web application, restarting from the
41 beginning after every code change can get pretty tedious. This module
42 allows you to reload your application classes on the fly, so that the
43 code/test cycle becomes a lot easier.
44
45 %description -l pl.UTF-8
46 Podczas programowania częste jest cykliczne przechodzenie między
47 pisaniem kodu i testowaniem go. Ogólnie testowanie dzieje się wewnątrz
48 zestawu testów, ale często wygodniej jest testować ręcznie przy
49 śledzeniu błędu albo podczas badania przy kodowaniu. W wielu
50 sytuacjach jednak jest to niewygodne - np. w REPL czy stanowych
51 aplikacjach WWW, restartowanie od początku przy każdej zmianie kodu
52 może być męczące. Ten moduł pozwala przeładować klasy aplikacji w
53 locie, dzięki czemu cykl kodowanie-testowanie staje się dużo
54 łatwiejszy.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 # this does some temp dir hackery that fails on builders
60 %{__rm} t/moose-metaclasses.t
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} pure_install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes README
81 %{perl_vendorlib}/Class/Refresh.pm
82 %{_mandir}/man3/Class::Refresh.3pm*
This page took 0.169967 seconds and 4 git commands to generate.