]> git.pld-linux.org Git - packages/perl-Class-Multimethods.git/blob - perl-Class-Multimethods.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Multimethods.git] / perl-Class-Multimethods.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Multimethods
7 Summary:        Class::Multimethods - support multimethods and function overloading in Perl
8 Summary(pl.UTF-8):      Class::Multimethods - obsługa wielometod i przeciążania funkcji w Perlu
9 Name:           perl-Class-Multimethods
10 Version:        1.70
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5fdc79daa81b102b956b1a61531fd6a7
17 URL:            http://search.cpan.org/dist/Class-Multimethods/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Class::Multimethod module exports a subroutine (&multimethod) that
25 can be used to declare other subroutines that are dispatched using a
26 algorithm different from the normal Perl subroutine or method dispatch
27 mechanism.
28
29 %description -l pl.UTF-8
30 Moduł Class::Multimethod eksportuje funkcję (&multimethod), która może
31 być użyta do deklarowania innych funkcji, które mogą być wysyłane przy
32 użyciu innego algorytmu niż normalnie używany przez Perla dla funkcji
33 lub metod.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 perl -ni -e 'BEGIN{undef $/}print "#!/usr/bin/perl\n$_"' demo/*.pl
53 cp -a demo/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Change* *.html
61 %{perl_vendorlib}/%{pdir}/*.pm
62 %{_mandir}/man3/*
63 %dir %{_examplesdir}/%{name}-%{version}
64 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.279664 seconds and 4 git commands to generate.