]> git.pld-linux.org Git - packages/perl-Class-Mix.git/blob - perl-Class-Mix.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Mix.git] / perl-Class-Mix.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Mix
7 Summary:        Class::Mix - dynamic class mixing
8 Name:           perl-Class-Mix
9 Version:        0.006
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  14f9d08abf878afc1592f3861cf98be4
16 URL:            http://search.cpan.org/dist/Class-Mix/
17 BuildRequires:  perl-Params-Classify
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The mix_class function provided by this module dynamically generates
25 `anonymous' classes with specified inheritance.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Build.PL \
32         --destdir=$RPM_BUILD_ROOT \
33         --installdirs=vendor
34 ./Build
35
36 %{?with_tests:./Build test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 ./Build install
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %{perl_vendorlib}/Class/Mix.pm
49 %{_mandir}/man3/*
This page took 0.359121 seconds and 4 git commands to generate.