]> git.pld-linux.org Git - packages/perl-Class-Fields.git/blob - perl-Class-Fields.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Fields.git] / perl-Class-Fields.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    Fields
7 Summary:        Class::Fields - inspect the fields of a class
8 Summary(pl.UTF-8):      Class::Fields - doglądanie składowych klasy
9 Name:           perl-Class-Fields
10 Version:        0.204
11 Release:        1
12 License:        unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  22874976c81830bed35b5988d3879aee
16 URL:            http://search.cpan.org/dist/Class-Fields/
17 BuildRequires:  perl-Carp-Assert
18 BuildRequires:  perl(base) >= 2.0
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       perl(base) >= 2.0
22 Requires:       perl-base >= 1:5.8.1
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A collection of utility functions/methods for examining the data
28 members of a class. It provides a nice, high-level interface that
29 should stand the test of time and Perl upgrades nicely.
30
31 %description -l pl.UTF-8
32 Zestaw funkcji i metod narzędziowych do sprawdzania składowych
33 klasy. Dają przyjemny, wysokopoziomowy interfejs, który powinien
34 wytrzymać próbę czasu i uaktualnienia Perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 rm t/bugs.t     # expected warning has changed; try to remove it after 0.201
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
59 %{perl_vendorlib}/%{pdir}/%{pnam}
60 %{perl_vendorlib}/*.pm
61 %{_mandir}/man3/*
This page took 0.081058 seconds and 4 git commands to generate.