]> git.pld-linux.org Git - packages/perl-Carp-Assert.git/blob - perl-Carp-Assert.spec
4f9f9152f52ceb47f0527c14e40ee70c894c9d98
[packages/perl-Carp-Assert.git] / perl-Carp-Assert.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Carp
7 %define         pnam    Assert
8 Summary:        Carp::Assert - executable comments
9 Summary(pl.UTF-8):      Carp::Assert - wykonywalne komentarze
10 Name:           perl-Carp-Assert
11 Version:        0.20
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Carp/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9dafe361b9e5e93e8e3e70e015f6b191
18 URL:            http://search.cpan.org/dist/Carp-Assert/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl-Pod-Tests >= 0.18
22 BuildRequires:  perl-Test-Simple >= 0.40
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Carp::Assert is intended for a purpose like the ANSI C library
30 assert.h. An assertion is used to prevent the impossible from being
31 asked of your code, or at least tell you when it does.
32
33 %description -l pl.UTF-8
34 Moduł Carp::Assert służy do tego, co assert.h z ANSI C. Używa się
35 zapewnień (assertion), aby wykluczyć występowanie rzeczy niemożliwych,
36 albo przynajmniej wiedzieć, gdzie się zdarzają.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Carp/Assert.pm
61 %{_mandir}/man3/*
This page took 0.135556 seconds and 2 git commands to generate.