]> git.pld-linux.org Git - packages/perl-Cache.git/blob - perl-Cache.spec
910c50f52fb18a2d6522bbe5d92303aa4c0a082e
[packages/perl-Cache.git] / perl-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Cache
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Cache - the cache interface
8 Summary(pl.UTF-8):      Cache - interfejs buforujący
9 Name:           perl-Cache
10 Version:        2.04
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  c64b8dd8f04e101bd20cde0c7c2e3d17
17 URL:            http://search.cpan.org/dist/Cache/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Date::Parse) >= 2.24
22 BuildRequires:  perl-DB_File >= 1.72
23 BuildRequires:  perl-Digest-SHA1 >= 2.01
24 BuildRequires:  perl-File-NFSLock >= 1.2
25 BuildRequires:  perl-Heap >= 0.01
26 BuildRequires:  perl-IO-String >= 1.02
27 BuildRequires:  perl-Storable >= 1
28 BuildRequires:  perl-Test-Simple >= 0.45
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The Cache modules are designed to assist a developer in persisting
35 data for a specified period of time. Often these modules are used in
36 web applications to store data locally to save repeated and redundant
37 expensive calls to remote machines or databases.
38
39 The Cache interface is implemented by derived classes that store
40 cached data in different manners (such as files on a filesystem, or in
41 memory).
42
43 %description -l pl.UTF-8
44 Moduły Cache są zaprojektowane, aby pomagać programistom w
45 przechowywaniu danych przez określony okres czasu. Zwykle moduły te są
46 używane w aplikacjach WWW do lokalnego przechowywania danych w celu
47 zaoszczędzenia powtarzających się i nadmiarowych drogich wywołań do
48 zdalnych maszyn lub baz danych.
49
50 Interfejs Cache jest zaimplementowany poprzez klasy dziedziczące
51 przechowujące buforowane dane na różne sposoby (np. w plikach albo w
52 pamięci).
53
54 %prep
55 %setup -q -n %{pdir}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes LICENSE README TODO
76 %{perl_vendorlib}/*.pm
77 %{perl_vendorlib}/Cache/*
78 %{_mandir}/man3/*
This page took 0.201624 seconds and 2 git commands to generate.