]> git.pld-linux.org Git - packages/perl-CPAN.git/blob - perl-CPAN.spec
- we don't distribute Bundle modules (thanks radek)
[packages/perl-CPAN.git] / perl-CPAN.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    CPAN
7 Summary:        CPAN Perl module - query, download and build Perl modules from CPAN sites
8 Summary(pl):    Modu³ Perla CPAN - odpytywanie, ¶ci±ganie i budowanie modu³ów Perla z serwisów CPAN
9 Name:           perl-CPAN
10 Version:        1.71
11 Release:        1
12 License:        ?
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  fafac3333492ac1161e605a00a79c48e
16 %if %{?_without_tests:0}%{!?_without_tests:1}
17 BuildRequires:  perl(File::Spec)
18 BuildRequires:  perl-Test-Simple
19 %endif
20 BuildRequires:  rpm-perlprov
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The CPAN module is designed to automate the make and install of perl
26 modules and extensions. It includes some searching capabilities and
27 knows how to use Net::FTP or LWP (or lynx or an external ftp client)
28 to fetch the raw data from the net.
29
30 %description -l pl
31 Modu³ CPAN s³u¿y do automatyzacji procesu budowania i instalowania
32 modu³ów i rozszerzeñ Perla. Ma mo¿liwo¶æ wyszukiwania i u¿ywania
33 Net::FTP lub LWP (albo lynksa czy zewnêtrznego klienta ftp) do
34 ¶ci±gania danych z sieci.
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor 
42 %{__make}
43
44 %{!?_without_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc ChangeLog Todo
57 %attr(755,root,root) %{_bindir}/cpan
58 %{perl_vendorlib}/*.pm
59 %{perl_vendorlib}/%{pdir}/*.pm
60 %{_mandir}/man1/*
61 %{_mandir}/man3/C*
This page took 0.054959 seconds and 4 git commands to generate.