]> git.pld-linux.org Git - packages/perl-CPAN.git/blob - perl-CPAN.spec
3b561f4186ac8199b91a3d755d70887ee4a5f25f
[packages/perl-CPAN.git] / perl-CPAN.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CPAN
7 Summary:        CPAN Perl module - query, download and build Perl modules from CPAN sites
8 Summary(pl.UTF-8):      Moduł Perla CPAN - odpytywanie, ściąganie i budowanie modułów Perla z serwisów CPAN
9 Name:           perl-CPAN
10 Version:        1.9205
11 Release:        1
12 License:        unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  779a03a6c79bf81b0e5a463f0593bbbf
16 %if %{with tests}
17 BuildRequires:  perl-Test-Simple
18 %endif
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The CPAN module is designed to automate the make and install of perl
26 modules and extensions. It includes some searching capabilities and
27 knows how to use Net::FTP or LWP (or lynx or an external FTP client)
28 to fetch the raw data from the net.
29
30 %description -l pl.UTF-8
31 Moduł CPAN służy do automatyzacji procesu budowania i instalowania
32 modułów i rozszerzeń Perla. Ma możliwość wyszukiwania i używania
33 Net::FTP lub LWP (albo lynksa czy zewnętrznego klienta FTP) do
34 ściągania danych z sieci.
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc ChangeLog Todo
58 %attr(755,root,root) %{_bindir}/cpan
59 %{perl_vendorlib}/*.pm
60 %dir %{perl_vendorlib}/CPAN
61 %{perl_vendorlib}/CPAN/*.pm
62 %{_mandir}/man1/*
63 %{_mandir}/man3/C*
This page took 0.075678 seconds and 3 git commands to generate.