]> git.pld-linux.org Git - packages/perl-CPAN-Meta-Check.git/blob - perl-CPAN-Meta-Check.spec
- macros for perl autodeps
[packages/perl-CPAN-Meta-Check.git] / perl-CPAN-Meta-Check.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Meta-Check
7 Summary:        CPAN::Meta::Check - Verify requirements in a CPAN::Meta object
8 Summary(pl.UTF-8):      CPAN::Meta::Check - sprawdzanie wymagań w obiekcie CPAN::Meta
9 Name:           perl-CPAN-Meta-Check
10 Version:        0.014
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ccd4448a7b08e1e3ef6f475030b282c9
17 Patch0:         fixdeps.patch
18 URL:            https://metacpan.org/release/CPAN-Meta-Check
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl(Exporter) >= 5.57
25 BuildRequires:  perl-CPAN-Meta >= 2.132830
26 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.121
27 BuildRequires:  perl-Module-Metadata >= 1.000023
28 BuildRequires:  perl-Test-Deep
29 BuildRequires:  perl-Test-Simple >= 0.88
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module verifies if requirements described in a CPAN::Meta object
36 are present.
37
38 %description -l pl.UTF-8
39 Ten moduł weryfikuje, czy zależności (wymagane moduły) opisane w
40 obiekcie CPAN::Meta są spełnione.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/CPAN/Meta/Check.pm
66 %{_mandir}/man3/CPAN::Meta::Check.3pm*
This page took 0.059921 seconds and 4 git commands to generate.