]> git.pld-linux.org Git - packages/perl-CPAN-Meta-Check.git/blob - perl-CPAN-Meta-Check.spec
3b41138e6255a67ba1993a12524db17bc46509c5
[packages/perl-CPAN-Meta-Check.git] / perl-CPAN-Meta-Check.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Meta-Check
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CPAN::Meta::Check - Verify requirements in a CPAN::Meta object
9 Name:           perl-CPAN-Meta-Check
10 Version:        0.005
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d6c84386c77298468d35a4e03eda6719
17 Patch0:         fixdeps.patch
18 URL:            http://search.cpan.org/dist/CPAN-Meta-Check/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Deep
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module verifies if requirements described in a CPAN::Meta object
29 are present.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33 %patch0 -p1
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes INSTALL README
54 %{perl_vendorlib}/CPAN/Meta/*.pm
55 %{_mandir}/man3/*
This page took 0.072782 seconds and 3 git commands to generate.