]> git.pld-linux.org Git - packages/perl-CGI.git/blob - perl-CGI.spec
- real summaries, updated noautoreq, license format unification,
[packages/perl-CGI.git] / perl-CGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CGI
7 %define         pnam    CGI
8 Summary:        CGI Perl module - simple CGI interface class
9 Summary(pl):    Modu³ Perla CGI - prosta klasa interfejsu do CGI
10 Name:           perl-CGI
11 Version:        3.04
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}.pm-%{version}.tar.gz
18 # Source0-md5:  abeca476bd3c2119e489c1a4fe6c3ed2
19 BuildRequires:  rpm-perlprov >= 4.3-0.20030610.20.2
20 BuildRequires:  perl-devel
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreq      perl(FCGI)
25
26 %description
27 CGI is an easy-to-use Perl5 library for writing World Wide Web CGI
28 scripts. This is replacement for usually outdated CGI module from perl
29 distribution.
30
31 %description -l pl
32 CGI jest modu³em to prostego i szybkiego pisania aplikacji dla WWW -
33 skryptów CGI. Pakiet ten zawiera zamiennik dla zazwyczaj starej wersji
34 modu³u CGI która jest dostarczana razem z perlem.
35
36 %package examples
37 Summary:        Examples for the CGI module
38 Summary(pl):    Przyk³ady u¿ycia modu³u CGI
39 Group:          Development/Languages/Perl
40 Requires:       %{name} = %{epoch}:%{version}
41
42 %description examples
43 Examples for the CGI module.
44
45 %description examples -l pl
46 Przyk³ady u¿ycia modu³u CGI.
47
48 %prep
49 %setup -q -n %{pnam}.pm-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README *.html
73 %{perl_vendorlib}/CGI.pm
74 %{perl_vendorlib}/CGI/*
75 %{_mandir}/man3/*
76
77 %files examples
78 %defattr(644,root,root,755)
79 %dir %{_examplesdir}/%{name}-%{version}
80 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.cgi
81 %{_examplesdir}/%{name}-%{version}/*.[!c]*
82 %{_examplesdir}/%{name}-%{version}/WORLD*
This page took 0.038488 seconds and 4 git commands to generate.