]> git.pld-linux.org Git - packages/perl-CGI.git/blob - perl-CGI.spec
- up to 3.59
[packages/perl-CGI.git] / perl-CGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CGI
7 Summary:        CGI Perl module - simple CGI interface class
8 Summary(pl.UTF-8):      Moduł Perla CGI - prosta klasa interfejsu do CGI
9 Name:           perl-CGI
10 Version:        3.59
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/CGI/MARKSTOS/%{pdir}.pm-%{version}.tar.gz
17 # Source0-md5:  d8ad35c14ba4c471fe07be6e54bb05a6
18 URL:            http://search.cpan.org/dist/CGI.pm/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.3-0.20030610.20.2
21 BuildRequires:  sed >= 4.0
22 %if %{with tests}
23 BuildRequires:  perl-Encode
24 BuildRequires:  perl-FCGI >= 0.67
25 BuildRequires:  perl-Test-Simple >= 0.98
26 BuildRequires:  perl(File::Spec) >= 0.82
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreq      perl(FCGI)
32
33 %description
34 CGI is an easy-to-use Perl5 library for writing World Wide Web CGI
35 scripts. This is replacement for usually outdated CGI module from perl
36 distribution.
37
38 %description -l pl.UTF-8
39 CGI jest modułem do prostego i szybkiego pisania aplikacji dla WWW -
40 skryptów CGI. Pakiet ten zawiera zamiennik dla zazwyczaj starej wersji
41 modułu CGI która jest dostarczana razem z perlem.
42
43 %package examples
44 Summary:        Examples for the CGI module
45 Summary(pl.UTF-8):      Przykłady użycia modułu CGI
46 Group:          Development/Languages/Perl
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48
49 %description examples
50 Examples for the CGI module.
51
52 %description examples -l pl.UTF-8
53 Przykłady użycia modułu CGI.
54
55 %prep
56 %setup -q -n %{pdir}.pm-%{version}
57
58 %{__sed} -i -e 's|/usr/local/bin/perl|/usr/bin/perl|g' examples/*.{cgi,pl}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_examplesdir}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes README *.html
82 %{perl_vendorlib}/CGI.pm
83 %{perl_vendorlib}/CGI/*.pm
84 %{_mandir}/man3/CGI*.3pm*
85
86 %files examples
87 %defattr(644,root,root,755)
88 %dir %{_examplesdir}/%{name}-%{version}
89 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.cgi
90 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
91 %{_examplesdir}/%{name}-%{version}/*.gif
92 %{_examplesdir}/%{name}-%{version}/*.html
93 %{_examplesdir}/%{name}-%{version}/*.xbm
94 %{_examplesdir}/%{name}-%{version}/WORLD_WRITABLE
This page took 0.035585 seconds and 4 git commands to generate.