]> git.pld-linux.org Git - packages/perl-CGI.git/blob - perl-CGI.spec
- updated to 3.52
[packages/perl-CGI.git] / perl-CGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    CGI
7 Summary:        CGI Perl module - simple CGI interface class
8 Summary(pl.UTF-8):      Moduł Perla CGI - prosta klasa interfejsu do CGI
9 Name:           perl-CGI
10 Version:        3.52
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/CGI/MARKSTOS/%{pdir}.pm-%{version}.tar.gz
17 # Source0-md5:  6ec43c8777713175e71ad9b19598899f
18 URL:            http://search.cpan.org/dist/CGI.pm/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.3-0.20030610.20.2
21 BuildRequires:  sed >= 4.0
22 %if %{with tests}
23 BuildRequires:  perl-FCGI
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      perl(FCGI)
29
30 %description
31 CGI is an easy-to-use Perl5 library for writing World Wide Web CGI
32 scripts. This is replacement for usually outdated CGI module from perl
33 distribution.
34
35 %description -l pl.UTF-8
36 CGI jest modułem do prostego i szybkiego pisania aplikacji dla WWW -
37 skryptów CGI. Pakiet ten zawiera zamiennik dla zazwyczaj starej wersji
38 modułu CGI która jest dostarczana razem z perlem.
39
40 %package examples
41 Summary:        Examples for the CGI module
42 Summary(pl.UTF-8):      Przykłady użycia modułu CGI
43 Group:          Development/Languages/Perl
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45
46 %description examples
47 Examples for the CGI module.
48
49 %description examples -l pl.UTF-8
50 Przykłady użycia modułu CGI.
51
52 %prep
53 %setup -q -n %{pdir}.pm-%{version}
54
55 %{__sed} -i -e 's|/usr/local/bin/perl|/usr/bin/perl|g' examples/*.{cgi,pl}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_examplesdir}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README *.html
79 %{perl_vendorlib}/CGI.pm
80 %{perl_vendorlib}/CGI/*.pm
81 %{_mandir}/man3/CGI*.3pm*
82
83 %files examples
84 %defattr(644,root,root,755)
85 %dir %{_examplesdir}/%{name}-%{version}
86 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.cgi
87 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
88 %{_examplesdir}/%{name}-%{version}/*.gif
89 %{_examplesdir}/%{name}-%{version}/*.html
90 %{_examplesdir}/%{name}-%{version}/*.xbm
91 %{_examplesdir}/%{name}-%{version}/WORLD_WRITABLE
This page took 0.040208 seconds and 4 git commands to generate.