]> git.pld-linux.org Git - packages/perl-CGI-Session.git/blob - perl-CGI-Session.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Session.git] / perl-CGI-Session.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %define         pdir    CGI
6 %define         pnam    Session
7 Summary:        CGI::Session - persistent storage of complex data in CGI
8 Summary(pl.UTF-8):      CGI::Session - trwałe przechowywanie złożonych struktur danych w CGI
9 Name:           perl-CGI-Session
10 Version:        4.48
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7f8983aaeb92a0ba77eca8bca6d8d43a
17 URL:            http://search.cpan.org/dist/CGI-Session/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-DB_File
23 BuildRequires:  perl-FreezeThaw
24 BuildRequires:  perl-CGI-Simple
25 BuildRequires:  perl-YAML-Syck
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 CGI::Session is Perl5 library that provides an easy persistent session
32 management system across HTTP requests.
33
34 %description -l pl.UTF-8
35 CGI::Session jest biblioteką dla Perla5, udostępniającą łatwy system
36 zarządzania trwałą sesją pomiędzy zapytaniami HTTP.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %{perl_vendorlib}/CGI/*.pm
61 %{perl_vendorlib}/CGI/Session
62 %{_mandir}/man3/*
This page took 0.060421 seconds and 3 git commands to generate.