]> git.pld-linux.org Git - packages/perl-CGI-Persistent.git/blob - perl-CGI-Persistent.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Persistent.git] / perl-CGI-Persistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Persistent
7 Summary:        CGI::Persistent - transparent state persistence for CGI applications
8 Summary(pl.UTF-8):      CGI::Persistent - przezroczyste zachowywanie stanu dla aplikacji CGI
9 Name:           perl-CGI-Persistent
10 Version:        1.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b91c3cabb9c5e2029522ad8937959a19
17 URL:            http://search.cpan.org/dist/CGI-Persistent/
18 BuildRequires:  perl-CGI
19 BuildRequires:  perl-Persistence-Object-Simple
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 HTTP is a stateless protocol; a HTTP server closes connection after
27 serving an object. It retains no memory of the request details and
28 doesn't relate subsequent requests with what it has already served.
29
30 CGI::Persistent solves this problem by introducing persistent CGI
31 sessions that store their state data on the server side. When a new
32 session starts, CGI::Persistent automatically generates a unique state
33 identification string and associates it with a persistent object on
34 the server. The identification string is used in URLs or forms to
35 refer to the particular session. Request attributes are transparently
36 committed to the associated object and the object data is bound to the
37 query.
38
39 CGI::Persistent is derived from CGI.pm. CGI.pm methods have been
40 overridden as appropriate. Very few new methods have been added.
41
42 %description -l pl.UTF-8
43 HTTP jest protokołem bezstanowym; serwer HTTP zamyka połączenie po
44 podaniu obiektu. Nie przechowuje w pamięci szczegółów dotyczących
45 żądań i nie wiąże następnych żądań z tym, co już zostało podane.
46
47 CGI::Persistent rozwiązuje ten problem wprowadzając trwałe sesje CGI
48 przechowujące dane o stanie po stronie serwera. Kiedy zaczyna się nowa
49 sesja, CGI::Persistent automatycznie generuje unikalny łańcuch
50 identyfikujący stan i wiąże go z trwałym obiektem na serwerze. Łańcuch
51 identyfikujący jest używany w URL-ach lub formularzach, aby wskazywał
52 na konkretną sesję. Atrybuty żądania są w sposób przezroczysty
53 dodawane do powiązanego obiektu, a dane obiektu są przypisane do
54 zapytania.
55
56 CGI::Persistent wywodzi się z CGI.pm, którego metody zostały
57 odpowiednio przykryte. Dodano tylko kilka nowych metod.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %{perl_vendorlib}/CGI/Persistent.pm
82 %{_mandir}/man3/*
This page took 0.266911 seconds and 4 git commands to generate.