]> git.pld-linux.org Git - packages/perl-CGI-Minimal.git/blob - perl-CGI-Minimal.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Minimal.git] / perl-CGI-Minimal.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    CGI
6 %define         pnam    Minimal
7 Summary:        CGI::Minimal - a lightweight CGI form processing package
8 Summary(pl.UTF-8):      CGI::Minimal - lekki pakiet do przetwarzania formularzy CGI
9 Name:           perl-CGI-Minimal
10 Version:        1.29
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  76c659dc5f32018d2158d2427d549f35
17 URL:            http://search.cpan.org/dist/CGI-Minimal/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package provides a micro-weight alternative to the CPAN CGI.pm
25 module. Rather than attempt to address every possible need of a CGI
26 programmer, it provides the _minimum_ functions needed for CGI such as
27 form decoding (including file upload forms), URL encoding and
28 decoding, HTTP usable date generation (RFC1123 compliant dates) and
29 _basic_ escaping and unescaping of HTMLized text.
30
31 The form decoding interface is somewhat compatible with the CGI.pm
32 module. No provision is made for generating HTTP or HTML on your
33 behalf - you are expected to be conversant with how to put together
34 any HTML or HTTP you need.
35
36 %description -l pl.UTF-8
37 Ten pakiet dostarcza bardzo lekką alternatywę dla modułu CPAN CGI.pm.
38 Zamiast próbować sprostać wszelkim możliwym potrzebom programisty CGI,
39 ten moduł dostarcza _minimalne_ funkcje potrzebne dla CGI, takie jak
40 dekodowanie formularzy (włącznie z przysyłaniem plików), kodowanie i
41 dekodowanie URL-i, generowanie użytecznego w HTTP formatu daty
42 (zgodnego z RFC1123) oraz _podstawowe_ traktowanie znaków specjalnych
43 (escape/unescape) w tekście HTML.
44
45 Interfejs do dekodowania formularzy jest częściowo kompatybilny z
46 modułem CGI.pm. Natomiast nie ma generowania HTTP czy HTML za
47 programistę - to on ma wiedzieć, jak umieścić potrzebny mu HTML czy
48 HTTP.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/CGI/Minimal.pod
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README TODO
75 %{perl_vendorlib}/CGI/Minimal.pm
76 %{perl_vendorlib}/CGI/Minimal
77 %{_mandir}/man3/*
This page took 0.082244 seconds and 4 git commands to generate.