]> git.pld-linux.org Git - packages/perl-CGI-Fast.git/blob - perl-CGI-Fast.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Fast.git] / perl-CGI-Fast.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CGI
6 %define         pnam    Fast
7 Summary:        CGI::Fast - CGI Interface for Fast CGI
8 Name:           perl-CGI-Fast
9 Version:        2.10
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  7c1d93600b796b9a0eb6fa3558d3d0c1
16 URL:            http://search.cpan.org/dist/CGI-Fast/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-CGI >= 4
21 BuildRequires:  perl-FCGI >= 0.67
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 CGI::Fast is a subclass of the CGI object created by CGI.pm.  It is
28 specialized to work with the FCGI module, which greatly speeds up CGI
29 scripts by turning them into persistently running server processes.
30 Scripts that perform time-consuming initialization processes, such as
31 loading large modules or opening persistent database connections, will
32 see large performance improvements.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/CGI/Fast.pm
57 %{_mandir}/man3/*
This page took 0.055494 seconds and 4 git commands to generate.