]> git.pld-linux.org Git - packages/perl-CGI-Expand.git/blob - perl-CGI-Expand.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Expand.git] / perl-CGI-Expand.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    CGI
6 %define pnam    Expand
7 Summary:        CGI::Expand - convert flat hash to nested data using TT2's dot convention
8 #Summary(pl.UTF-8):     
9 Name:           perl-CGI-Expand
10 Version:        2.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  81830498565fc71a0bc5476adf9440b9
17 URL:            http://search.cpan.org/dist/CGI-Expand/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Exception
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Converts a CGI query into structured data using a dotted name convention
28 similar to TT2.  
29
30 # %description -l pl.UTF-8
31 # TODO
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes
55 %{perl_vendorlib}/CGI/*.pm
56 %{_mandir}/man3/*
This page took 0.087771 seconds and 3 git commands to generate.