]> git.pld-linux.org Git - packages/perl-CGI-Compile.git/blob - perl-CGI-Compile.spec
79b13722f50ce56a96bb448a3a66e7e1b7506d09
[packages/perl-CGI-Compile.git] / perl-CGI-Compile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Compile
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        CGI::Compile - Compile .cgi scripts to a code reference like ModPerl::Registry
9 Name:           perl-CGI-Compile
10 Version:        0.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2fcf4bc473107130229f4e0a98c756ce
17 URL:            http://search.cpan.org/dist/CGI-Compile/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(File::pushd)
22 BuildRequires:  perl(Test::NoWarnings)
23 BuildRequires:  perl-Test-Requires
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 CGI::Compile is an utility to compile CGI scripts into a code
30 reference that can run many times on its own namespace, as long as the
31 script is ready to run on a persistent environment.
32
33 NOTE: for best results, load CGI::Compile before any modules used by
34 your CGIs.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/CGI/*.pm
59 %{_mandir}/man3/*
This page took 0.054063 seconds and 2 git commands to generate.