]> git.pld-linux.org Git - packages/perl-Barcode-Code128.git/blob - perl-Barcode-Code128.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Barcode-Code128.git] / perl-Barcode-Code128.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %define         pdir    Barcode
6 %define         pnam    Code128
7 Summary:        Barcode::Code128 - Perl module for generating CODE 128 bar codes
8 Summary(pl.UTF-8):      Barcode::Code128 - moduł Perla do generowania kodów paskowych CODE 128
9 Name:           perl-Barcode-Code128
10 Version:        2.01
11 Release:        1
12 License:        Public Domain
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Barcode/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  a0aa077b26926c30659471d14515d907
16 URL:            http://search.cpan.org/dist/Barcode-Code128/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Barcode::Code128 generates bar codes using the CODE 128 symbology. It
24 can generate images in PNG or GIF format using the GD package, or it
25 can generate a text string representing the barcode that you can
26 render using some other technology if desired.
27
28 %description -l pl.UTF-8
29 Barcode::Code128 generuje kody paskowe przy użyciu symboli CODE 128.
30 Może generować obrazki w formacie PNG lub GIF przy użyciu pakietu GD
31 albo tekst reprezentujący kod paskowy, który można zrenderować w inny
32 sposób.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 # module generates correct image, but a bit different to
37 # the one included in the distribution and compared with
38 mv t/png.t{,.broken}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Barcode/Code128.pm
61 %{_mandir}/man3/*
This page took 0.099805 seconds and 4 git commands to generate.