]> git.pld-linux.org Git - packages/perl-B-Hooks-EndOfScope.git/blob - perl-B-Hooks-EndOfScope.spec
- macros for perl autodeps
[packages/perl-B-Hooks-EndOfScope.git] / perl-B-Hooks-EndOfScope.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    B
6 %define pnam    Hooks-EndOfScope
7 Summary:        B::Hooks::EndOfScope - Execute code after a scope finished compilation
8 Summary(pl.UTF-8):      B::Hooks::EndOfScope - wykonywanie kodu po skompilowaniu zakresu kodu
9 Name:           perl-B-Hooks-EndOfScope
10 Version:        0.24
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/B/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  99a48be0694dfd12b40482c6a495e10f
17 URL:            https://metacpan.org/release/B-Hooks-EndOfScope
18 BuildRequires:  perl-ExtUtils-CBuilder >= 0.26
19 BuildRequires:  perl-ExtUtils-MakeMaker
20 BuildRequires:  perl-devel >= 1:5.8.1
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-Module-Implementation >= 0.05
25 BuildRequires:  perl-Sub-Exporter-Progressive >= 0.001006
26 BuildRequires:  perl-Test-Simple >= 0.89
27 BuildRequires:  perl-Variable-Magic >= 0.48
28 %endif
29 Requires:       perl-Module-Implementation >= 0.05
30 Requires:       perl-Module-Runtime >= 0.012
31 Requires:       perl-Sub-Exporter-Progressive >= 0.001006
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreq_perl Tie::StdHash
36
37 %description
38 This module allows you to execute code when Perl finished compiling
39 the surrounding scope.
40
41 %description -l pl.UTF-8
42 Ten moduł pozwala na wykonanie kodu po zakończeniu kompilacji
43 otaczającego zakresu kodu przez interpreter Perla.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         --skipdeps \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %dir %{perl_vendorlib}/B/Hooks
69 %{perl_vendorlib}/B/Hooks/EndOfScope.pm
70 %{perl_vendorlib}/B/Hooks/EndOfScope
71 %{_mandir}/man3/B::Hooks::EndOfScope*.3pm*
This page took 0.083413 seconds and 3 git commands to generate.