]> git.pld-linux.org Git - packages/perl-B-Graph.git/blob - perl-B-Graph.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-B-Graph.git] / perl-B-Graph.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    B
6 %define         pnam    Graph
7 Summary:        B::Graph - Perl compiler backend to produce graphs of OP trees
8 Summary(pl.UTF-8):      B::Graph - backend dla kompilatora Perla tworzący grafy drzew OP
9 Name:           perl-B-Graph
10 Version:        0.51
11 Release:        10
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/B/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  907943809a96d8ff9f0118a64e40e723
17 Patch0:         %{name}-perl5.10.patch
18 URL:            http://search.cpan.org/dist/B-Graph/
19 BuildRequires:  perl-devel >= 1:5.10.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 B::Graph module is a backend to the Perl compiler (B::*) which,
26 instead of outputting bytecode or C based on Perl's compiled version
27 of a program, writes descriptions in graph-description languages
28 specifying graphs that show the program's structure. It currently
29 generates descriptions for the VCG tool
30 (<http://www.cs.uni-sb.de/RW/users/sander/html/gsvcg1.html>) and Dot
31 (part of the graph visualization toolkit from AT&T:
32 <http://www.research.att.com/sw/tools/graphviz/>). It also can produce
33 plain text output (which is more useful for debugging the module
34 itself than anything else).
35
36 %description -l pl.UTF-8
37 Moduł B::Graph jest backendem dla kompilatora Perla (B::*), który
38 zamiast generować kod pośredni lub kod C w oparciu kompilowaną wersję
39 programu perlowego, wypisuje opisy w językach opisu grafów, tworząc
40 grafy ukazujące strukturę programu. Aktualnie generuje on opisy dla
41 narzędzi: VCG
42 (<http://www.cs.uni-sb.de/RW/users/sander/html/gsvcg1.html>) oraz Dot
43 (część zestawu narzędziowego AT&T do wizualizacji
44 grafów: <http://www.research.att.com/sw/tools/graphviz/>). Potrafi on
45 również generować czysto tekstowy wynik (który jest bardziej przydatny
46 do odpluskwiania samego modułu, niż do czegokolwiek innego).
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50 %patch0 -p1
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/B/Graph.pm
72 %{_mandir}/man3/B::Graph.3pm*
This page took 0.105832 seconds and 4 git commands to generate.