]> git.pld-linux.org Git - packages/perl-Audio-MPD-Common.git/blob - perl-Audio-MPD-Common.spec
c60ddfac9999ae483b38bf5d5239f6bfd0a54751
[packages/perl-Audio-MPD-Common.git] / perl-Audio-MPD-Common.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define pdir    Audio
8 %define pnam    MPD-Common
9 Summary:        Audio::MPD::Common - a bunch of common helper classes for mpd
10 Summary(pl.UTF-8):      Audio::MPD::Common - zwstaw wspólnych klas pomocniczych dla mpd
11 Name:           perl-Audio-MPD-Common
12 Version:        0.1.3
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Audio/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  30d319cb5acb5c3e066ccd63c3465549
19 URL:            http://search.cpan.org/dist/Audio-MPD-Common/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl-Class-Accessor
24 BuildRequires:  perl-Readonly
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Depending on whether you're using a POE-aware environment or not,
31 people wanting to tinker with mpd (Music Player Daemon) will use
32 either POE::Component::Client::MPD or Audio::MPD.
33
34 But even if the run-cores of those two modules differ completely, they
35 are using the exact same common classes to represent the various mpd
36 states and information. Therefore, those common classes have been
37 outsourced to Audio::MPD::Common.
38
39 %description -l pl.UTF-8
40 W zależności od korzystania ze środowiska POE osoby chcące manipulować
41 przy demonie mpd (Music Player Daemon) używają
42 POE::Component::Client::MPD lub Audio::MPD.
43
44 Ale nawet jeśli oba te moduły różnią się całkowicie sposobem
45 działania, używają dokładnie tych samych wspólnych klas
46 reprezentujących różne stany i informacje o mpd. W związku z tym
47 wspólne klasy zostały wydzielone do pakietu Audio::MPD::Common.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Build.PL \
54         destdir=$RPM_BUILD_ROOT \
55         installdirs=vendor
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %dir %{perl_vendorlib}/Audio/MPD
72 %{perl_vendorlib}/Audio/MPD/*.pm
73 %{perl_vendorlib}/Audio/MPD/Common
74 %{_mandir}/man3/*
This page took 0.11403 seconds and 2 git commands to generate.