]> git.pld-linux.org Git - packages/perl-Astro-FITS-CFITSIO.git/blob - perl-Astro-FITS-CFITSIO.spec
perl 5.38.0 rebuild
[packages/perl-Astro-FITS-CFITSIO.git] / perl-Astro-FITS-CFITSIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %define         pdir    Astro
6 %define         pnam    FITS-CFITSIO
7 Summary:        Astro::FITS::CFITSIO - Perl extension for using the cfitsio library
8 Summary(pl.UTF-8):      Astro::FITS::CFITSIO - rozszerzenie Perla do korzystania z biblioteki cfitsio
9 Name:           perl-Astro-FITS-CFITSIO
10 Version:        1.15
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Astro/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b192177a6756655c74361d766ba43cbc
17 URL:            https://metacpan.org/release/Astro-FITS-CFITSIO
18 BuildRequires:  cfitsio-devel >= 3.480
19 BuildRequires:  perl-ExtUtils-PkgConfig
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       cfitsio >= 3.480
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Astro::FITS::CFITSIO is a Perl interface to William Pence's cfitsio
27 subroutine library.
28
29 This module attempts to provide a wrapper for nearly every cfitsio
30 routine, while retaining as much cfitsio behavior as possible. As
31 such, one should be aware that it is still somewhat low-level, in the
32 sense that handing an array which is not the correct size to a routine
33 like fits_write_img() may cause SIGSEGVs.
34
35 The goal is to eventually use these routines to build a more Perl-like
36 interface to many common tasks such as reading and writing of images
37 and ASCII and binary tables.
38
39 %description -l pl.UTF-8
40 Astro::FITS::CFITSIO jest perlowym interfejsem do biblioteki cfitsio
41 Williama Pence'a.
42
43 Ten moduł jest próbą dostarczenia obudowania dla prawie wszystkich
44 funkcji cfitsio przy zachowaniu możliwie najbliższym cfitsio. Przez to
45 trzeba mieć na uwadze, że dostęp jest nieco niskopoziomowy, w tym
46 sensie, że przekazanie tablicy o złym rozmiarze do funkcji typu
47 fits_write_img() może powodować SIGSEGV.
48
49 Celem autora jest ewentualne wykorzystanie tych funkcji to stworzenia
50 bardziej perlowego interfejsu do wielu ogólnych zadań, takich jak
51 odczyt i zapis obrazów oraz tablic binarnych i ASCII.
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55
56 %build
57 export CFITSIO=/usr
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ChangeLog NOTES README TODO
79 %{perl_vendorarch}/Astro/FITS
80 %dir %{perl_vendorarch}/auto/Astro/FITS
81 %dir %{perl_vendorarch}/auto/Astro/FITS/CFITSIO
82 %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/autosplit.ix
83 %attr(755,root,root) %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/CFITSIO.so
84 %{_mandir}/man3/Astro::FITS::CFITSIO.3pm*
85 %dir %{_examplesdir}/%{name}-%{version}
86 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
87 %{_examplesdir}/%{name}-%{version}/INDEX
88 %{_examplesdir}/%{name}-%{version}/*.fits.*
This page took 0.110794 seconds and 4 git commands to generate.