]> git.pld-linux.org Git - packages/perl-App-SVN-Bisect.git/blob - perl-App-SVN-Bisect.spec
- locale fix.
[packages/perl-App-SVN-Bisect.git] / perl-App-SVN-Bisect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    App
7 %define pnam    SVN-Bisect
8 Summary:        App::SVN::Bisect - binary search through svn revisions
9 Name:           perl-App-SVN-Bisect
10 Version:        1.0
11 Release:        1
12 License:        artistic_2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/App/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d8540f354b27d904eee56cc473542cbc
16 Patch0:         %{name}-locale.patch
17 URL:            http://search.cpan.org/dist/App-SVN-Bisect/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(IO::All) > 0.38
22 BuildRequires:  perl-Test-Exception
23 BuildRequires:  perl-Test-Output
24 BuildRequires:  perl-YAML-Syck
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module implements the backend of the "svn-bisect" command line
31 tool. See the POD documentation of that tool, for usage details.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35 %patch0 -p1
36
37 %build
38 %{__perl} Build.PL \
39         destdir=$RPM_BUILD_ROOT \
40         installdirs=vendor
41
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README TODO
57 %attr(755,root,root) %{_bindir}/svn-bisect
58 %{perl_vendorlib}/App/SVN/*.pm
59 %{_mandir}/man3/*
60 %{_mandir}/man1/*
This page took 0.056165 seconds and 4 git commands to generate.