]> git.pld-linux.org Git - packages/perl-App-SVN-Bisect.git/blob - perl-App-SVN-Bisect.spec
- initial checkin (thx agaran).
[packages/perl-App-SVN-Bisect.git] / perl-App-SVN-Bisect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    App
7 %define pnam    SVN-Bisect
8 Summary:        App::SVN::Bisect - binary search through svn revisions
9 Name:           perl-App-SVN-Bisect
10 Version:        1.0
11 Release:        1
12 License:        artistic_2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/App/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d8540f354b27d904eee56cc473542cbc
16 URL:            http://search.cpan.org/dist/App-SVN-Bisect/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(IO::All) > 0.38
21 BuildRequires:  perl-Test-Exception
22 BuildRequires:  perl-Test-Output
23 BuildRequires:  perl-YAML-Syck
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module implements the backend of the "svn-bisect" command line
30 tool. See the POD documentation of that tool, for usage details.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Build.PL \
37         destdir=$RPM_BUILD_ROOT \
38         installdirs=vendor
39
40 ./Build
41
42 %{?with_tests:./Build test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 ./Build install
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README TODO
55 %attr(755,root,root) %{_bindir}/svn-bisect
56 %{perl_vendorlib}/App/SVN/*.pm
57 %{_mandir}/man3/*
58 %{_mandir}/man1/*
This page took 0.099171 seconds and 4 git commands to generate.