]> git.pld-linux.org Git - packages/perl-App-CLI.git/blob - perl-App-CLI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-App-CLI.git] / perl-App-CLI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    App
6 %define         pnam    CLI
7 Summary:        App::CLI - Dispatcher module for command line interface programs
8 Summary(pl.UTF-8):      App:CLI - Moduł obsługi programów z interfejsem CLI
9 Name:           perl-App-CLI
10 Version:        0.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/C/CL/CLKAO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  efa1b227460477c2141c691fa7824170
17 URL:            http://search.cpan.org/dist/App-CLI/
18 BuildRequires:  perl-Locale-Maketext-Simple
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Getopt::Long) >= 2.35
23 BuildRequires:  perl(Pod::Simple::Text)
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 App::CLI dispatches CLI (command line interface) based commands into
30 command classes. It also supports subcommand and per-command options.
31
32 %description -l pl.UTF-8
33 App::CLI przekazuje komendy wydawane z linii poleceń do klas je
34 obsługujących. Obsługuje także podkomendy oraz opcje dla każdej z
35 komend.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %{perl_vendorlib}/App/*.pm
60 %{perl_vendorlib}/App/CLI
61 %{_mandir}/man3/*
This page took 0.067541 seconds and 3 git commands to generate.