]> git.pld-linux.org Git - packages/perl-Apache-LogFormat-Compiler.git/blob - perl-Apache-LogFormat-Compiler.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Apache-LogFormat-Compiler.git] / perl-Apache-LogFormat-Compiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         pdir    Apache
6 %define         pnam    LogFormat-Compiler
7 Summary:        Apache::LogFormat::Compiler - Compile a log format string to perl-code
8 Name:           perl-Apache-LogFormat-Compiler
9 Version:        0.35
10 Release:        1
11 License:        Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  cbb0bf041ade8a39f65eadbdf8a346c1
15 URL:            http://search.cpan.org/dist/Apache-LogFormat-Compiler/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 3.0.3-26
18 %if %{with tests}
19 BuildRequires:  perl-HTTP-Message
20 BuildRequires:  perl-POSIX-strftime-Compiler
21 BuildRequires:  perl-Try-Tiny
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Compile a log format string to Perl-code. For faster generation of
27 access_log lines.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Build.PL \
34                 --destdir=$RPM_BUILD_ROOT \
35                 --installdirs=vendor
36 ./Build
37
38 %{?with_tests:./Build test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 ./Build install
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %dir %{perl_vendorlib}/%{pdir}/LogFormat
51 %{perl_vendorlib}/%{pdir}/LogFormat/*.pm
52 %{_mandir}/man3/*.3*
This page took 0.12101 seconds and 3 git commands to generate.