]> git.pld-linux.org Git - packages/perl-Algorithm-Huffman.git/blob - perl-Algorithm-Huffman.spec
- formatting
[packages/perl-Algorithm-Huffman.git] / perl-Algorithm-Huffman.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Algorithm
7 %define         pnam    Huffman
8 Summary:        Algorithm::Huffman - implementation of the Huffman algorithm
9 Summary(pl):    Algorithm::Huffman - implementacja algorytmu Huffmana
10 Name:           perl-Algorithm-Huffman
11 Version:        0.09
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  dd5c0360357dcb0807e9ac2e49b2e746
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Heap
21 BuildRequires:  perl-Scalar-List-Utils
22 BuildRequires:  perl-String-Random
23 BuildRequires:  perl-Test-Exception
24 BuildRequires:  perl-Test-ManyParams
25 BuildRequires:  perl-Test-Simple
26 BuildRequires:  perl-Tree-DAG_Node
27 %endif
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This modules implements the huffman algorithm. The aim is to create
34 a good coding scheme for a given list of different characters (or even
35 strings) and their occurence numbers.
36
37 %description -l pl
38 Ten modu³ jest implementacj± algorytmu Huffmana. Celem jest stworzenie
39 dobrze koduj±cego schematu dla danej listy ró¿nych znaków (lub nawet
40 ci±gów) i liczby ich wyst±pieñ.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Change*
64 %{perl_vendorlib}/%{pdir}/*.pm
65 %{_mandir}/man3/*
This page took 0.105299 seconds and 3 git commands to generate.