]> git.pld-linux.org Git - packages/openssh.git/commitdiff
- updated (fixes for current libselinux)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 26 Feb 2004 18:45:43 +0000 (18:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    openssh-selinux.patch -> 1.5

openssh-selinux.patch

index 73bf4a98fc176fe09fab46a3c902039316d0a031..a1dbff2ea225980cea67e975e994545d97ff6e6d 100644 (file)
@@ -1,25 +1,3 @@
-diff -urN openssh-3.7.1p2.org/Makefile.in openssh-3.7.1p2/Makefile.in
---- openssh-3.7.1p2.org/Makefile.in    2003-12-26 20:14:52.000000000 +0100
-+++ openssh-3.7.1p2/Makefile.in        2003-12-26 20:15:15.000000000 +0100
-@@ -40,7 +40,7 @@
- CC=@CC@
- LD=@LD@
--CFLAGS=@CFLAGS@
-+CFLAGS=@CFLAGS@ -DWITH_SELINUX
- CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
- LIBS=@LIBS@
- LIBPAM=@LIBPAM@
-@@ -134,7 +134,7 @@
-       $(LD) -o $@ $(SSHOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
- sshd$(EXEEXT): libssh.a       $(LIBCOMPAT) $(SSHDOBJS)
--      $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBS)
-+      $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBS) -lselinux
- scp$(EXEEXT): $(LIBCOMPAT) libssh.a scp.o progressmeter.o
-       $(LD) -o $@ scp.o progressmeter.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
-diff -urN openssh-3.7.1p2.org/session.c openssh-3.7.1p2/session.c
 --- openssh-3.7.1p2.org/session.c      2003-12-26 20:14:53.000000000 +0100
 +++ openssh-3.7.1p2/session.c  2003-12-26 20:15:50.000000000 +0100
 @@ -62,6 +62,11 @@
@@ -39,7 +17,7 @@ diff -urN openssh-3.7.1p2.org/session.c openssh-3.7.1p2/session.c
        if (getuid() != pw->pw_uid || geteuid() != pw->pw_uid)
                fatal("Failed to set uids to %u.", (u_int) pw->pw_uid);
 +#ifdef WITH_SELINUX
-+      if (is_selinux_enabled())
++      if (is_selinux_enabled()>0)
 +        {
 +          security_context_t scontext;
 +          if (get_default_context(pw->pw_name,NULL,&scontext))
@@ -73,7 +51,7 @@ diff -urN openssh-3.7.1p2.org/session.c openssh-3.7.1p2/session.c
         * tty is owned by root.
         */
 +#ifdef WITH_SELINUX
-+      if (is_selinux_enabled()) {
++      if (is_selinux_enabled()>0) {
 +        security_context_t      new_tty_context=NULL,
 +          user_context=NULL, old_tty_context=NULL; 
 +
@@ -112,3 +90,23 @@ diff -urN openssh-3.7.1p2.org/session.c openssh-3.7.1p2/session.c
        }
 +
  }
+--- openssh-3.7.1p2.org/Makefile.in    2003-12-26 20:14:52.000000000 +0100
++++ openssh-3.7.1p2/Makefile.in        2003-12-26 20:15:15.000000000 +0100
+@@ -40,7 +40,7 @@
+ CC=@CC@
+ LD=@LD@
+-CFLAGS=@CFLAGS@
++CFLAGS=@CFLAGS@ -DWITH_SELINUX
+ CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
+ LIBS=@LIBS@
+ LIBPAM=@LIBPAM@
+@@ -134,7 +134,7 @@
+       $(LD) -o $@ $(SSHOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
+ sshd$(EXEEXT): libssh.a       $(LIBCOMPAT) $(SSHDOBJS)
+-      $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBS)
++      $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBS) -lselinux
+ scp$(EXEEXT): $(LIBCOMPAT) libssh.a scp.o progressmeter.o
+       $(LD) -o $@ scp.o progressmeter.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
This page took 0.033881 seconds and 4 git commands to generate.