]> git.pld-linux.org Git - packages/openssh.git/commitdiff
- rel 2; generate ed25519 server key auto/th/openssh-6.5p1-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 2 Mar 2014 07:35:45 +0000 (08:35 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 2 Mar 2014 07:35:45 +0000 (08:35 +0100)
openssh.spec
opensshd.init
sshd-keygen

index ab19b5a721b5b9f46546c6aae30fe17e14a7b9e7..efda783d4dc058b496e346e06b98d825bb130a7e 100644 (file)
@@ -34,7 +34,7 @@ Summary(ru.UTF-8):    OpenSSH - свободная реализация прото
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
 Version:       6.5p1
-Release:       1
+Release:       2
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
index ab59061b6e528a458878d3b90b8e1d42cd5d7d17..a00a9dad600e334dfac703197d0b47a306732402 100755 (executable)
@@ -67,6 +67,11 @@ ssh_gen_keys() {
                chmod 600 /etc/ssh/ssh_host_ecdsa_key
                [ -x /sbin/restorecon ] && /sbin/restorecon /etc/ssh/ssh_host_ecdsa_key
        fi # ecdsa
+       if [ ! -f /etc/ssh/ssh_host_ed25519_key -o ! -s /etc/ssh/ssh_host_ed25519_key ]; then
+               /usr/bin/ssh-keygen -t ed25519 -f /etc/ssh/ssh_host_ed25519_key -N '' >&2
+               chmod 600 /etc/ssh/ssh_host_ed25519_key
+               [ -x /sbin/restorecon ] && /sbin/restorecon /etc/ssh/ssh_host_ed25519_key
+       fi # ed25519
 }
 
 start() {
index 94ac509de8c4b738cb199f3b665c8914db154fca..1f2b320710d7b48238878e0aa7c7044ca983468f 100644 (file)
@@ -24,5 +24,9 @@ if [ ! -f /etc/ssh/ssh_host_ecdsa_key -o ! -s /etc/ssh/ssh_host_ecdsa_key ]; the
        chmod 600 /etc/ssh/ssh_host_ecdsa_key
        [ -x /sbin/restorecon ] && /sbin/restorecon /etc/ssh/ssh_host_ecdsa_key
 fi # ecdsa
-
+if [ ! -f /etc/ssh/ssh_host_ed25519_key -o ! -s /etc/ssh/ssh_host_ed25519_key ]; then
+       /usr/bin/ssh-keygen -t ed25519 -f /etc/ssh/ssh_host_ed25519_key -N '' >&2
+       chmod 600 /etc/ssh/ssh_host_ed25519_key
+       [ -x /sbin/restorecon ] && /sbin/restorecon /etc/ssh/ssh_host_ed25519_key
+fi # ed25519
 exit 0
This page took 0.043814 seconds and 4 git commands to generate.