]> git.pld-linux.org Git - packages/openssh.git/commitdiff
- up to 6.1p1 auto/th/openssh-6.1p1-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 2 Sep 2012 21:19:40 +0000 (23:19 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 2 Sep 2012 21:19:40 +0000 (23:19 +0200)
authorized-keys-command.patch
openssh.spec

index 3c171f4e867a9975c72c5777405088f45d623ed6..0d56398163c9b7d240abb205433e392c36037552 100644 (file)
 @@ -324,6 +326,7 @@ typedef enum {
        sZeroKnowledgePasswordAuthentication, sHostCertificate,
        sRevokedKeys, sTrustedUserCAKeys, sAuthorizedPrincipalsFile,
-       sKexAlgorithms, sIPQoS,
+       sKexAlgorithms, sIPQoS, sVersionAddendum,
 +      sAuthorizedKeysCommand, sAuthorizedKeysCommandRunAs,
        sDeprecated, sUnsupported
  } ServerOpCodes;
  
 @@ -448,6 +451,13 @@ static struct {
-       { "authorizedprincipalsfile", sAuthorizedPrincipalsFile, SSHCFG_ALL },
        { "kexalgorithms", sKexAlgorithms, SSHCFG_GLOBAL },
        { "ipqos", sIPQoS, SSHCFG_ALL },
+       { "versionaddendum", sVersionAddendum, SSHCFG_GLOBAL },
 +#ifdef WITH_AUTHORIZED_KEYS_COMMAND
 +      { "authorizedkeyscommand", sAuthorizedKeysCommand, SSHCFG_ALL },
 +      { "authorizedkeyscommandrunas", sAuthorizedKeysCommandRunAs, SSHCFG_ALL },
        M_CP_INTOPT(permit_empty_passwd);
  
 @@ -1758,6 +1784,8 @@ dump_config(ServerOptions *o)
-       dump_cfg_string(sRevokedKeys, o->revoked_keys_file);
        dump_cfg_string(sAuthorizedPrincipalsFile,
            o->authorized_principals_file);
+       dump_cfg_string(sVersionAddendum, o->version_addendum);
 +      dump_cfg_string(sAuthorizedKeysCommand, o->authorized_keys_command);
 +      dump_cfg_string(sAuthorizedKeysCommandRunAs, o->authorized_keys_command_runas);
  
 --- openssh-5.9p1/servconf.h   2011-06-23 00:30:03.000000000 +0200
 +++ openssh-5.9p1/servconf.h   2011-09-13 01:17:16.481674272 +0200
 @@ -166,6 +166,8 @@ typedef struct {
-       char   *revoked_keys_file;
-       char   *trusted_user_ca_keys;
        char   *authorized_principals_file;
+       char   *version_addendum;       /* Appended to SSH banner */
 +      char   *authorized_keys_command;
 +      char   *authorized_keys_command_runas;
  }       ServerOptions;
       AuthorizedKeysFile
               Specifies the file that contains the public keys that can be used
               for user authentication.  The format is described in the
-@@ -401,7 +418,8 @@ DESCRIPTION
+@@ -419,7 +419,8 @@ DESCRIPTION
               Only a subset of keywords may be used on the lines following a
-              Match keyword.  Available keywords are AllowAgentForwarding,
--             AllowTcpForwarding, AuthorizedKeysFile, AuthorizedPrincipalsFile,
-+             AllowTcpForwarding, AuthorizedKeysFile, AuthorizedKeysCommand,
-+             AuthorizedKeysCommandRunAs, AuthorizedPrincipalsFile,
-              Banner, ChrootDirectory, ForceCommand, GatewayPorts,
-              GSSAPIAuthentication, HostbasedAuthentication,
+              Match keyword.  Available keywords are AcceptEnv,
+              AllowAgentForwarding, AllowGroups, AllowTcpForwarding,
+-             AllowUsers, AuthorizedKeysFile, AuthorizedPrincipalsFile, Banner,
++             AllowUsers, AuthorizedKeysFile, AuthorizedKeysCommand,
++             AuthorizedPrincipalsFile, Banner,
+              ChrootDirectory, DenyGroups, DenyUsers, ForceCommand,
+              GatewayPorts, GSSAPIAuthentication, HostbasedAuthentication,
               HostbasedUsesNameFromPacketOnly, KbdInteractiveAuthentication,
 --- openssh-5.9p1/sshd_config.5        2011-08-05 22:17:33.000000000 +0200
 +++ openssh-5.9p1/sshd_config.5        2011-09-13 01:17:16.536674498 +0200
index 44914e9aaabe5e14c055ff2799a437ed5b8774d6..46709cb7cf1bcdafa747892cd13eb34a77735c5e 100644 (file)
@@ -1,3 +1,7 @@
+# TODO:
+# - add trigger to enable this:
+#  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
+#   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
 #
 # Conditional build:
 %bcond_without audit           # sshd audit support
@@ -30,13 +34,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       6.0p1
-Release:       3
+Version:       6.1p1
+Release:       1
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 3c9347aa67862881c5da3f3b1c08da7b
+# Source0-md5: 3345cbf4efe90ffb06a78670ab2d05d5
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
This page took 0.063279 seconds and 4 git commands to generate.